Nextcloud

Login

Nextcloud is only accessible by MousePaw Media staff. To log in, navigate to https://nextcloud.mousepawmedia.net and enter your company LDAP credentials.

If you have difficulty logging in, contact the IT department.

Nextcloud Quota

To keep our file space usage under control, each user has been issued a quota. Most users have a 1GB quota.

What Is a Quota?

If you’re not familiar with this concept, every file has a file size. A file’s size is a measurement of how much computer memory it takes up. File size is usually measured in KB, MB, and GB.

Your quota is the total amount of computer memory you can use on the server. For example, if you’ve uploaded ten 5 MB files, you’ve used a total of 50 MB from your quota.

Managing Your Quota

You can view your quota and usage by clicking your username in the upper-right corner and selecting Personal. The used and available quota is displayed at the top.

Most documents, spreadsheets, presentation and text files are fairly small files, unless they have a lot of media embedded in them.

Photos, audio, and video files are much larger (especially video), so you should be mindful of their size when uploading. Higher resolution photos, uncompressed audio, and high resolution video take up more space.

Some media files should be stored as high resolution, especially those being used for production. Media used only for internal reference, on the other hand, can usually be stored in a compressed format (such as .ogg instead of .wav) or a lower resolution (such as 800 x 450 instead of 7680 x 4320).

Raising Your Quota

If you need more space, you can ask an administrator to raise your quota. Before you do, however, we recommend following these steps:

  1. Search through your files for anything you no longer need, and thus can remove.
  2. Ensure your media files are optimized for storage, depending on their purpose. (see Managing Your Quota)
  3. Think carefully about how much extra space you need. Are you uploading something necessary? Can you change any habits to make better use of your quota space?

If you are certain you need more space, contact an administrator and request that your quota be raised to a particular size (preferably in GB). Please be sure to explain why you need the extra space.

Basic Structure

Nextcloud offers a few different Apps, which you can switch between from the top bar.

  • Files allows you to browse through your files and folders. (See Files).
  • Activity lists all of the recent activity on Nextcloud.
  • Gallery lets you view and browse all the photos on Nextcloud.
  • Circles allows you to create custom groups for sharing.
  • Notes is a place to quickly store notes for yourself. (Not collaborative.)
  • Announcements shows the latest news.
  • Bookmarks allows you to store internet bookmarks and access them from any device. (Not collaborative.)
  • Tasks is your personal task list. (Not collaborative.)

Note

You should still be using Phabricator Maniphest for project tasks, so your teammates can see them. The Nextcloud Tasks app is only for personal work tasks, such as “Read ‘Dreaming in Code’” or “Clean desk”.

Clicking the gear on the right side of the top bar brings up another menu. This gives you access to your profile (Personal), Nextcloud’s official documentation (Help), and the ability to sign out of your account (Log out).

Most of these applications are self-explanatory. Thus, for brevity, we will only be covering Files and Collabora Office here. If you need other help, contact IT.

Files

The Files application allows you to browse, arrange, add, and remove files from Nextcloud. The interface is divided into three panes:

  • The left-most pane allows you to filter your files by various criteria. Usually, you’ll use All files when browsing and managing files.
  • The center pane allows you to browse files and directories, and perform many file management tasks.
  • The right pane appears when you select many options from the center pane.

Browsing Files

To open a folder or file, click its name in the center pane.

At the top of the center pane is a “breadcrumb trail” which displays your location in the folder structure. Clicking the Home icon on the left end of the breadcrumb trail takes you to the base directory.

Adding and Uploading

The + button towards the top of the center pane allows you to create or upload a new item at the current location.

You can upload nearly any kind of file to Nextcloud.

  • Image files (.jpg, .png, .gif, .svg, etc.) can be viewed directly via the Gallery app.
  • Document files (*.odt, *.doc, *.docx) can be viewed and edited via the Office (Document) app.
  • Spreadsheet files (*.ods, *.xls, *.xlsx) can be viewed and edited via the Office (Spreadsheet) app.
  • Presentation files (*.odp, *.ppt, *.pptx) can be viewed and edited via the Office (Presentation) app.
  • PDF files can be viewed directly via the built-in PDF viewer.
  • Text files (*.txt) can be viewed and edited directly via the built-in Text editor.
  • Many video files can be viewed directly via the built-in Video player.

Important

You should keep an eye on your file space quota. See Nextcloud Quota.

Managing Files

On each file/folder’s row on the center pane, you’ll see the following controls (moving from left to right)...

  • The Star button marks a file as favorite.
  • Clicking the item icon toggles its selection. Selecting multiple items allows you to perform various file actions on them in bulk.
  • Click the item name opens it.
  • The Share button opens the sharing tab in the right pane. (See Sharing Files).
  • The Menu button (the three dots) opens the actions menu.
    • Details shows information and history about the item in the right pane. (See File Details and Versions).
    • Rename allows you to rename the item.
    • Download downloads the current version of the item to your computer. If you download a folder, it will download all of the contents in a .zip file.
    • Delete deletes the file. (See Restoring Files).
  • The file size is displayed in KB, MB, or GB.
  • The date the file was last modified is displayed last on the row.

Sharing Files

You can share any item with other users from the Sharing tab in the right pane. If you don’t see it, you can open it by tapping the Sharing icon on an item row in the center pane.

Note

When sharing a lot of related files, it is usually better to put them all in one folder, and then share the folder itself.

To share an item, start typing a username (i.e. “jcmcdonald”) or group name (i.e. “Content Developers”) in the Share with users or groups... box. Tap the name when it appears in the autocomplete list.

Note

You must search users by their username. You presently cannot search by their real name.

After selecting a user or group, they will appear in the sharing list below the search box. You can control sharing permissions from here.

  • Can share means the user/group can share the item with other users/groups.
  • Can edit means the user/group is able to edit the item.
  • The trash can icon un-shares the item with the user/group.

Important

For Design+Production or Content Development, it is usually most convenient to place uploaded work into a folder and share it with your entire department, using the department’s group name.

File Details and Versions

The right pane of te Files app allows you to control details about each folder and file. If you don’t see this pane, click the Menu button (the three dots) on the item’s row in the center pane, and select Details.

At the top, you can see the file name, size, and date modified. You can set tags by clicking the Tags button. Type in the Collaborative tags box to search existing tags. You can also type a new tag name and press Enter to create one.

The Activities tab shows the history of the file.

Note

Any action attributed to “remote user” is due to a bug in the Office app. You can view more revision information in that app.

The Comments section allows you to discuss the item with other users.

The Sharing section allows you to share the file with other users and groups (see Sharing Files).

Lastly, Versions allows you to see and restore different versions of an item! You can download or restore any version displayed on the list. If you choose to restore an older version, you can still restore the newer version.

Restoring Files

If you accidentally delete a file, you can restore it. Select Deleted files from the lower-left corner of the Files app.

In the list, find the item you want to restore, and click the Restore button towards the right of the item’s row.

Office

Nextcloud has the latest version of Collabora Office built in. This allows us to collaboratively edit documents right from the web browser.

We are specifically running CODE. This is basically a special version of LibreOffice, designed and optimized for web browsers. For performance reasons, many extraneous editing features have been removed. However, it is capable of displaying documents the same as if you opened them in LibreOffice on your computer.

Limitations

Missing Features

For performance reasons, many of LibreOffice’s editing features have been omitted from Collabora Office.

While Collabora Office can display all OpenDocument format documents, spreadsheets, and presentations (among other document types and formats) almost identically to how LibreOffice displays them, it cannot necessary create or edit the more complex formatting.

Here are a few common examples:

  • Missing fonts may be substituted, without actually changing what font is called for in the document.
  • Complex formatting on documents is retained and usually displayed, but it cannot be created or modified.
  • Headers and footers are hidden on documents, although they still exist and are displayed in LibreOffice itself.

What this often means is that, while Collabora Office is fantastic for on-the-fly and collaborative editing, you will still need to use LibreOffice for formatting.

This is especially true of Presentations. The text and images can themselves be edited on Collabora Office, but themes, appearances, and effects will need to be edited on LibreOffice.

Performance

Collabora Office is a full application being served over the internet. Understandably, then, it needs a fairly good internet connection! You should take this into consideration when using it.

If your internet connection is slow or unreliable, you may experience lags in typing, applying changes, or seeing the collaborative changes of others. In the worst case, you might not be able to make any changes because they’re getting lost between your computer and the server.

Note

If you see your changes on the document, you can rest assured that they are indeed there.

If you are experiencing such issues, you may need to wait on using Collabora Office until you have a more reliable internet connection.

Creating and Opening Files

Collabora fully integrates with the Files application. Clicking the name of any office-format document (*.odt, *.docx, *.ods, *.odp, etc.) will open it in Collabora Office.

To create a new file, click the + button at the top center of the Files app, and select New Document, New Spreadsheet, or New Presentation.

The Editing Interface

When you open a file for editing, you’ll see the menubar and toolbar along the top. You’ll see different menus, buttons, and options depending on what kind of file you’re editing.

Toolbar

Different buttons appear on the toolbar, depending on what kind of file you’re editing. The button’s name will appear when you hover over the button.

  • Save saves the current document. (See File Menu).
  • Undo rolls back the last change. (See Edit Menu).
  • Redo restores the last rolled back change. (See Edit Menu).
  • Document repair brings up the document repair window. (See Edit Menu).
  • The Style Menu allows you to select a style for your current document selection.
  • The Slide Menu allows you to select a slide type for your current slide.
  • The Font Menu offers many common open-source fonts.
  • The Size Menu allows you to select a text size.
  • Bold, Italic, Underline, and Strikethrough are shortcuts for the four most common text formatting options. (See Format Menu).
  • Font color and Highlighting set the foreground and background colors for your text.
  • Align left, Center horizontally, Align right, and Justified set the text’s alignment. (See Format Menu).
  • Wrap text wraps the text within the cell.
  • Format as Currency, ...as Percent, ...as Number, or ...as Date will format the numbers in the current cell as indicated.
  • Add Decimal Place and Delete Decimal Place allow you to control the number of decimal places displayed in a number in the current cell.
  • Sort Ascending and Sort Descending will sort the selected cells.
  • Bullets on/off and Numbering on/off toggle the two kinds of lists available to you. (See Format Menu).
  • Increase Indent and Decrease Indent let you control the indentation of a paragraph (not just its first line). (See Format Menu).
  • Insert Table inserts a new table.
  • Insert comment inserts a comment at the current cursor position, cell, or selection. (See Insert Menu).
  • Insert graphic inserts an image from your computer. (See Insert Menu).
  • Special Character inserts a special character, which you select from a panel. (See Insert Menu).

Status Bar

A few more tools and controls are available on the status bar at the bottom of the interface.

  • You can search within the document using the Search box and the corresponding Previous and Next buttons.
  • On Documents, the current word and character count, as well as the current page number. are displayed.
  • On Spreadsheets, the current sheet number and count are displayed.
  • On Spreadsheets, the number of selected rows and columns is displayed.
  • Insert and Overwrite typing modes can be toggled with your computer’s Insert key.
  • On Spreadsheets, you can perform quick math on the selected cells by tapping the down arrow near the center of the status bar.
  • When the document does NOT have unsaved changes, Document Saved will appear on the status bar.
  • The user list displays the number of users currently viewing the document. Click this list to expand it, and then click a username to jump to that user’s position in the document.
  • You can move between pages using the Previous Page and Next Page buttons.
  • If available, Zoom controls appear on the right-most side of the status bar.

Spreadsheet Controls

When editing Spreadsheets, a few additional controls are available.

The second upper toolbar is where you type cell contents. The Sum and Function buttons can help with creating the two most common kinds of formulas.

Note

To my knowledge, all LibreOffice spreadsheet formulas and functions work, but you will have to manually type most of them.

The second to bottom toolbar visible when editing Spreadsheets allows you to navigate and control sheets. Use the arrows or tabs to move between sheets.

Right-click on a sheet tab to add, rename, or delete sheets.

Presentation Controls

When editing Presentations, a list of the current slides is displayed on the left side. You can navigate by clicking on a slide.

The Insert, Duplicate, and Delete Slide buttons are available at the bottom of this pane, in addition to the Fullscreen presentation button. (See Slide Menu).

Etherpad

Nextcloud also is integrated with Etherpad (see Using Etherpad), a collaborative text editor.

From the Files application, you can create a new Etherpad by clicking the + icon at the top center and selecting Pad.

The interface for Etherpad is the same whether accessed through Nextcloud or directly at pad.mousepawmedia.net. See Using Etherpad for usage instructions.

Installing Nextcloud Client

You may want to install the Nextcloud client, which allows you to sync your files to and from your computer or device.

Warning

The company Windows ban extends to accessing NextCloud. You may NOT access Nextcloud from Windows, whether via the web interface or the client.

To install the Nextcloud client on an Ubuntu-based system, run...

$ sudo add-apt-repository ppa:nextcloud-devs/client
$ sudo apt update
$ sudo apt install nextcloud-client

Once that installs, start the Nextcloud desktop sync client application. The setup wizard will appear the first time.

Set the server address to https://nextcloud.mousepawmedia.net and click Next. Enter your company login (LDAP) credentials and click Next again.

On the next screen, we’ll choose to select specific folders to sync. Click Choose what to sync and UNCHECK MLP. (That’s a large collection of videos you can just watch on Nextcloud online.) The other folders should be fine to sync, so leave the rest checked. Click OK.

The default sync folder is recommended, but you can change it if you like.

Finally, click Connect..., and then Finish. If you’re on Ubuntu, you’ll now see the Nextcloud icon on your top bar. It will alert you when changes are made to files, and will automatically sync to the server.

You can now interact directly with files on the Nextcloud server by adding, editing, and removing them within your Nextcloud directory in your home folder!

Next, let’s ensure the Nextcloud client starts when our computer does. Right-click the Nextcloud icon in your indicator area, and click Settings.... Select the General tab and ensure that Launch on System Startup is checked.

Feel free to tweak the other settings to your preference, and then click Close when you’re done.